Back to overview
Downtime

Unavailable | Billing & Game Panel

Apr 30 at 07:35pm HDT
Affected services
Billing Portal
Game Panel

Resolved
Apr 30 at 07:39pm HDT

The network issue was resolved and these websites should be restored.

Created
Apr 30 at 07:35pm HDT

We are currently investigating an outage on our billing and game panel website. More details will be available soon