Back to overview
Downtime
VPS Server s1.wa | Node Outage
Jan 24, 2025 at 4:03am UTC
Affected services
s1.wa
Resolved
Jan 24, 2025 at 9:47am UTC
All Fixed
Affected services
Created
Jan 24, 2025 at 4:03am UTC
We are working with our team to get this node back online as soon as possible.
Affected services